Drivers Tascam Sound Cards & Media Devices

12/10/2021by admin

This page lists the current status of TASCAM interface drivers for Windows 10 and Mac OS X 10.11. Even if your interface is compatible, please check that your DAW and other software is compatible before upgrading. If your interface is not listed, it is no longer possible to develop new drivers for that product.

Drivers Tascam Sound Cards & Media Devices Software

Drivers

Tascam Model 12 Driver

Pioneer DJ controllers for sale in Chicago, club and bar sound installation and rental shop for weddings DJ nightclubs, bar, pro bar speakers. DJ Turntables, DJ mixers, nightclub & stage lighting, audio studio gear, podcast, microphones and CDJ-2000NXS2. USB Audio / MIDI Interface. 16-input Audio Interface for Mac, Windows and iPad. Download TASCAM Sound Card drivers, firmware, bios, tools, utilities. TASCAM US-2000 Audio Interface Driver 2.00 for XP64/Vista64 783 downloads. Sound Card TASCAM. Windows Vista 64 bit, Windows XP 64 bit. Jan 1st 2012, 01:30 GMT.

Updated Jan 13, 2016:

Windows 10OS X El Capitan (10.11)
ASIO driver/
setting software
WDN driverFirmwareAudio/MIDISetting softwareFirmware
US-2x2v1.02 or higherv1.01 or higherCompatible/class complientv1.02 or higherv1.01 or higher
US-4x4v1.02 or higherv1.01 or higherCompatible/class complientv1.02 or higherv1.01 or higher
US-16x08v1.03 or higherv1.00 or higherCompatible/class complientv1.00 or higherv1.00 or higher
US-20x20v1.00 or higherv1.00 or higherCompatible/class complientv1.00 or higherv1.00 or higher
USB 3.0 requires OSX 10.11.2
UH-7000v1.02 or higherv1.07 or higherv1.30rc4 or higher
US-322v1.04 or higherv1.03 or higherv3.22rc5 or higher
US-366v1.04 or higherv1.03 or higherv3.22rc5 or higher
US-122MK2Currently testingCurrent version (driver v3.00d8/firmware v2.03) is not compatible.
A new version is under development.
US-144MK2Currently testingCurrent version (driver v3.00d8/firmware v2.03) is not compatible.
A new version is under development.
US-100ASIO is
not supported
Currently testingCurrently testing
US-125MASIO is
not supported
Currently testingCurrently testing
US-200Currently testingCompatible/class complient
US-600Currently testingCompatible/class complient
US-1200Currently testingv3.22rc1 or higher (beta release, El Capitan only)
US-1641Currently testingv3.22rc1 or higher (beta release, El Capitan only)
US-1800No need to update
v2.05 driver or higher is
compatible
No need to update
v1.00 firmware or later is
compatible
v3.0.21.b1 or higher (beta release, El Capitan only)v1.00 or higher
US-2000Currently testingv3.22rc1 or higher (beta release, El Capitan only)
IF-FW/DM mkIICurrently testingv1.30f10 or higher
Comments are closed.